Обсуждение:Single Player Commands

Материал из Minecraft Wiki
Перейти к: навигация, поиск

Как сказали недавно на Хабрахабре, "светло-салатовый цвет на белом фоне — не есть хорошо". Norrius 07:50, 15 июня 2011 (UTC)

Может лучше таблицей с двумя столбцами поставить (команда\значение), так вроде удобнее (ЗЫ: я таблицы чертить не умею=() По алфавиту поставить несложно, чем сегодня вечером и займусь.--Ниалас Агрен 08:46, 15 июня 2011 (UTC)
"я таблицы чертить не умею" - учитесь.
Уже=)--Ниалас Агрен 16:52, 17 июня 2011 (UTC)



Я слышал что через SPC можно добавить в инвентарь кирку которая разрушат локи с первого рза , читал список команд не нашел. Может проглядел? подскажите команду если такая есть,пожалуйста--C417 11:38, 31 июля 2011 (UTC)

Лично я не знаю про это. Однако есть мод WorldEdit в котором при помощи команды в консоли "//" можно сделать алмазную кирку волшебной, разрушающей блоки с одного раза. --Teksel 12:00, 31 июля 2011 (UTC)

О! вот это я и имел в виду, спасибо Teksel --C417 14:17, 31 июля 2011 (UTC)



Добрый день. Можно ли с помощью этого мода и команды /spawncontrol запретить спавниться всем мобам без исключения? Кстати, в обсуждении нельзя писать, если не зарегистрирован. Wiki же, разрешите.

Мне не удалось найти такую команду. Тут, например, про нее не знают. Возможно, Вы имели в виду что-то другое? А запрещение правок незарегистрированным участникам было сделано для защиты статей, обсуждений, шаблонов и т.д. от спама. Norrius 18:03, 14 сентября 2011 (UTC)
Понятно, спасибо. Кстати, здесь приведены не все команды. Кто-нибудь будет переводить? Было бы здорово.

Хм... возможно я слоупок,но где ж мне взять МодЛоадер той же версии, что и версия моей игры, если по ссылкам только одна версия даётся..?

Из гугла конечно. И вообщем то, да, стоит обновить ссылки на моды.--Bloodhit 13:59, 23 ноября 2011 (UTC)

Выполнил установку согласно всем инструкциям, но сообщение о версии SPC не появилось, чат недоступен. В чём может быть причина?

Переустанови мод. Все class файлы кинь в minecraft.jar, а jar файл в bin. --Operator 06:01, 22 апреля 2012 (UTC)


Все файлы добавил везде, где только можно. скриншот Мод по-прежнему не запускается.
Переустанови клиент(Force Update) и переустанови ещё раз. Папку craftscripts кинь в .minecraft, а если не запускается,

то перекачай мод. Хотя не знаю, у меня была такая же фигня с Aether. Operator 09:16, 23 апреля 2012 (UTC)

Проблему с модом решил, фокус в том, что в статье WorldEdit ссылка на устаревшую версию.

Интересно[править код]

Я когда попытался взорвать блок Админиума, введя /explode 18000000 (именно такой взрыв в 18 миллионов и нужен был), игра зависла, я вышел и запустил снова этот же мир, никакого взрыва не приизошло.

Ну тут дело не в Single Player Commands, а в вычислительных ресурсах клиента и машины. Вероятнее всего Ваш взрыв просто не успел просчитаться до того как Вы выключили игру.--mmankof 06:59, 6 мая 2012 (UTC)
Попробуйте написать перед этим /gamerule doTileDrops false. -- catnikita255 16:26, 25 марта 2013 (UTC)

Че за баг?[править код]

А вот интересно, я один раз включил и выключил команду damage, и теперь умираю от ЛЮБОГО удара (себя одной стрелой грохнул в железно-кольчуге с полной хилкой)Мне интересно, это у всех так? И если нет, как исправить? Klaster 08.06.2012

Скорее всего это баг, поскольку выходит какой-то диаметрально противоположный эффект. У меня подобного не было. --Teksel 11:22, 8 июня 2012 (UTC)

Чит-коды[править код]

Он требует включенность чит-кодов? Adeil

Нет. -- catnikita255 15:05, 31 марта 2013 (UTC)

Надо переписывать[править код]

Многие команды уже устарели надо переписать статью <Mister_Creeper>

//toggleeditwand[править код]

Команда //toggleeditwand не работает. Как можно отключить функцию выделения региона?

Да, как? Меня бесят сообщения First position set to .............! -- catnikita255 16:25, 25 марта 2013 (UTC)
Уберите один слэш. /toggleeditwand. Operator 12:37, 13 апреля 2013 (UTC)

Запрет разрушения блоков в одиночной игре[править код]

1. Возможно ли какими-либо средствами в одиночной игре ограничить разрушение определенных блоков, использование предметов и тп функции, присущие плагину WorldGuard для сервера. Возможно запретить игроку, если у него ник отличный от определенного совершать эти действия, или же запретить эти действия для gamemode 0 в отличие от креатив режима (gamemode 1)? --johnrodor 22:34, 14 июня 2013 (UTC)

Установка[править код]

Я не могу установить моды Single Player Commands и WorldEdit на 1.5.2 (специально ради SPC поставил). Пробовал автоматический установщик, пробовал вручную файлы закинуть в .jar — бесполезно. Лаунчер из Horse Update. Bedrock-сан (обс.) (вклад) 12:07, 16 июля 2013 (UTC)

Ладно, окей, выяснилось что этот мод можно поставить по инструкции только на чистый майн. Но у меня все равно есть вопрос: почему когда я при помощи деревянного топора кликаю левой кнопкой мыши по блоку, то он уничтожается а блок за ним (туда куда указывает курсор) считается первой точкой? Неужели отмечать область нельзя в креативе? И как же мне тогда выделять большие области если я не могу летать как в креативе? DimaD (На Curse) 02:00, 24 августа 2013 (UTC)
А как установить не на ванильный? --ChimMAG (обс.) 11:19, 31 июля 2014 (UTC)
На какую версию Minecraft? --Dand0 (обс.) 13:20, 31 июля 2014 (UTC)
1.6.4. Пока из двух модов - WorldEdit или SiglePlayerCommand смог установить первый. Путём долгого серфинга и скачиваний многих версий. --ChimMAG (обс.) 16:08, 31 июля 2014 (UTC)
Эммм... SPC официально не вышел на 1.6.4. Только 1.6.2 (В статье есть ссылка на форум). Откуда информация про версию на 1.6.4? А так, вот установка на версию 1.6.2:
1. Зайди в папку versions (она находится в папке .minecraft)
2. Сделай резервную копию папки 1.6.4-Forge-версия-forge.
3. Открой jar файл (он с иконкой чашечки кофе) используя архиватор и скопируй все файлы из файла мода в jar файл кроме WorldEdit.jar
4. Удали файлы из папки META-INF (В jar файле) кроме MANIFEST.MF
5. Закрой архиватор.
6. Скопируй файл WorldEdit.jar в .minecraft/bin
7. Открой json файл любым текстовым редактором и найди такую строку: "id": "1.6.4-Forge". Измени "1.6.4-Forge" на название папки версии.
8. Сохрани json файд.
9. Запусти Minecraft.
--Dand0 (обс.) 17:28, 31 июля 2014 (UTC)
Я умею читать википедию и иже с ней. Этот способ не работает у меня. Я извиняюсь, конечно, забыл добавить, что у меня сборка FTB Direwolf20. Это существенно, но я и оптифайн устанавливал на неё и DynamicLight, то есть слабые представления есть о том, как устанавливать что. А про совет. Папки version нету. Как и 1.6.4-Forge-версия-forge. Вместо них есть папка mods/1.6.4. Далее. Какой из трёх файлов JAR там отрывать? minecraft.jar? Так его давно нет в сборках. :-) Как и папки bin. Но я смог установить WorldEdit. Оказывается, что команда /delchunks не поддерживается. Это очень-очень плохо... --ChimMAG (обс.) 17:59, 31 июля 2014 (UTC)
Ты всё не понял. Скачайте неофициальную версию SPC от q3hardcore сдесь . Скачайте Magic Launcher отсюда. Запусти Magic Launcher, нажми setup, выбери свою forge версию, нажмите advanced, parameters, туда впиши без кавычек "-Dfml.ignoreInvalidMinecraftCertificates=true -Dfml.igonrePatchDiscrepancies=true". Потом откройте скачанный jar архиватором и скопируй файл WorldEdit.jar в папку .minecraft/mods/spc/. Запусти Minecraft из Magic Launcher. --Dand0 (обс.) 06:27, 1 августа 2014 (UTC)
Будет ли Magic Launcher работать со сборкой FTB? Сомневаюсь. Но я уже решил проблему. Вернее понял, что нужная функция в нём не работает - давно не обновлялась. --ChimMAG (обс.) 13:28, 1 августа 2014 (UTC)

Magic Launcher БУДЕТ работать с FTB!!! Потому, что FTB Direwolf'а использует FML (надеюсь вы знаете что это такое), и FML не будет различать, сборка это, или один единственный мод, он работает на одном принципе загрузки модов, и нет отдельного метода загрузки модов для сборок, поэтому Magic Launcher БУДЕТ работать с FTB. Прежде, чем думать, что чьё-то творение не будет работать со сборкой, включите логику! --Dand0 (обс.) 14:14, 1 августа 2014 (UTC)

Хммм... Не знал. Спасибо за информацию. --ChimMAG (обс.) 06:15, 2 августа 2014 (UTC)

Установка на лицуху[править код]

Здраствуйте, играю в майнкрафт через лицуху(я если че её купил так что не надо гнать).Я экспериментирую с установкой именно на лицуху. недавно возникла проблема что нужен spc. Мне нужно знать как устанавливать НА 1.5.2, и 1.8, 1.7.10. Важнее всего первая и вторая версия. Если кто знает как устанавливать подскажите:( TheLeonelus (обс.) 16:53, 29 декабря 2014 (UTC)

Minecraft Forge поставил? Если да, то закинь в папку /mods --Ilusha175 (обс.) 15:41, 14 марта 2015 (UTC)

Откатите (УЖЕ НЕ НАДО)[править код]

Справился, извините за оффтоп

http://minecraft-mods.org/single-player-commands-spc-mod/ --Ilusha175 (обс.) 15:36, 14 марта 2015 (UTC)